$re = '/\.Items\(.*?\)(\W.*(?!\.Select\(.+\)))?(\W.*)?\;/';
$str = 'Cars.Items()
.Where(x => x.Year == "1988")
.Select(x => new { x.Registration })
.ToList();
Cars.Items()
.Where(x => x.Id == 1923984)
.Select(x => new { x.Registration })
.FirstOrDefault;
Cars.Items()
.Where(x => x.Id == 1923984)
.FirstOrDefault;
Cars.Items();
Cars.Items()
.GroupBy(g => g.Key).First();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);