$re = '/reg(?:(ic)|ex)(?(1)es|(?:es)?)/m';
$str = 'regexes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);