package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)\ bag[s]?\ contain\ (?:(?:[1-9]\ (.+?)\ bag[s]?)(?:,\ [1-9]\ (.+?)\ bag[s]?)*|(?:no\ other\ bags)).$`)
var str = `dotted indigo bags contain 5 dotted lavender bags, 5 shiny gold bags, 1 vibrant tomato bag, 1 striped purple bag.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}