import re
regex = re.compile(r"\+?([ -]?\d+)+|\(\d+\)([ -]\d+)")
test_str = ("+62 361 222777\n"
"+62 813-444-5555 \n"
"+62 812-3333-3333\n"
"+62 811 391 2103 \n"
"+62 361-2277777\n"
"(0361) 227337\n"
"+62 8113912103\n"
"08134455555\n"
"0361-2277777\n"
"+62 812 3333 3333\n"
"+62 877 80803550\n"
"081339222111\n"
"081 339 222 111\n"
"+62 811338429196")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")