const regex = /(?:^|\&)([^;=]+);?=([^&]+)?(?=$|\&)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\&)([^;=]+);?=([^&]+)?(?=$|\\&)', 'gm')
const str = `_search=false&nd;=1566206479316&rows;=50&page;=2&sidx;=&sord;=desc&businessType;=&containerTypeId;=&operStatus;=&dispatchStatus;=&portId;=&customerId;=&billNo;=&orderNo;=&containerNo;=&customerOrderNo;=&yhNO;=&storageYardId;=&createBy;=&makeboxBeginDate;=2019-08-01&makeboxEndDate;=2019-08-19&dispatchGroupId;=&cityCode;=&salesmanid;=&relateAddrAddress;=
`;
const subst = `$1=$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);