re = /(?:^|\&)([^;=]+);?=([^&]+)?(?=$|\&)/m
str = '_search=false&nd;=1566206479316&rows;=50&page;=2&sidx;=&sord;=desc&businessType;=&containerTypeId;=&operStatus;=&dispatchStatus;=&portId;=&customerId;=&billNo;=&orderNo;=&containerNo;=&customerOrderNo;=&yhNO;=&storageYardId;=&createBy;=&makeboxBeginDate;=2019-08-01&makeboxEndDate;=2019-08-19&dispatchGroupId;=&cityCode;=&salesmanid;=&relateAddrAddress;=
'
subst = '$1=$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result