import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\W\\s(?<Item>[\\w\\s\\dA-Za-z]+?)\\s+?.+Price:";
final String string = "\"🌎 Probably #Israel only! 🌎\n"
+ "✔ Alfawise WM01 Wireless Mouse \n"
+ "💰 Price: 1.99 USD (~1.73 EUR) ❗ 🔥 (Best in my DB: 1.99 USD)\n"
+ "💵 Code = GBZY07wm\n"
+ "🌐 Link: http://bit.ly/2EzJWCv\n\n"
+ "🔎 Current: $1.99 | Average: $2.22 | 7 records in DB | Price monitoring since 19.9.2018 🔎\n\n"
+ "More country-specific coupons: https://couponsfromchina.com/2018/05/11/ultimate-country-specific-gearbest-coupons-list-gearbest/\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}