# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\W\s(?<Item>[\w\s\dA-Za-z]+?)\s+?.+Price:"
test_str = ("\"🌎 Probably #Israel only! 🌎\n"
"✔ Alfawise WM01 Wireless Mouse \n"
"💰 Price: 1.99 USD (~1.73 EUR) ❗ 🔥 (Best in my DB: 1.99 USD)\n"
"💵 Code = GBZY07wm\n"
"🌐 Link: http://bit.ly/2EzJWCv\n\n"
"🔎 Current: $1.99 | Average: $2.22 | 7 records in DB | Price monitoring since 19.9.2018 🔎\n\n"
"More country-specific coupons: https://couponsfromchina.com/2018/05/11/ultimate-country-specific-gearbest-coupons-list-gearbest/\"")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.