using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)";
string input = @"""Option 01 - Random phrase - Top Menu"",
""Option 02 - Another Random Phrase - Su Menu"",
""Option 03 - More 01 Phrase - Menu"",
""Option 04 - More Phrase -"",
""Option 05 - Simple Phrase"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}