import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\s+[-]\\s+.*?(?=\\s+-)|\\d+\\s+[-].*)";
final String string = "\"Option 01 - Random phrase - Top Menu\",\n"
+ "\"Option 02 - Another Random Phrase - Su Menu\",\n"
+ "\"Option 03 - More 01 Phrase - Menu\",\n"
+ "\"Option 04 - More Phrase -\",\n"
+ "\"Option 05 - Simple Phrase\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}