package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([1-9]|[1-9]\d)(\.?\d?\d?)$`)
var str = `4.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}