$re = '/^([1-9]|[1-9]\d)(\.?\d?\d?)$/';
$str = '4.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);