import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/[^\\\\\\/]+(?:\\\\.[^\\\\\\/]*)*){2}";
final String string = "/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20\n"
+ "/10/102-\\/ABC083.013\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20\n";
final String subst = "$0\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}