$re = '/(?:\/[^\\\\\/]+(?:\\\\.[^\\\\\/]*)*){2}/m';
$str = '/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
/10/102-\\/ABC083.013\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;