const regex = /\b[2-9][0-9]{3}\b(?<!2000)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[2-9][0-9]{3}\\b(?<!2000)', 'gm')
const str = `TAAD, Türkiye Adalet Akademisi'nin 95. Kuruluş Yıl Dönümü Armağanı, y.78, S.179, Temmuz 2023, s.108-157
1999
2000
9999
2001
99999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}