$re = '/\b[2-9][0-9]{3}\b(?<!2000)/m';
$str = 'TAAD, Türkiye Adalet Akademisi\'nin 95. Kuruluş Yıl Dönümü Armağanı, y.78, S.179, Temmuz 2023, s.108-157
1999
2000
9999
2001
99999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);