using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Q[A-Z ]*(?<!\b[A-Z]{2}Q)[\d.]+(*SKIP)(*F)|\d+(?:\.\d+)(?!\d*END$)";
string input = @"ABC WS YMQ234.03WS TOY234.03USD468.06END
FUR BB LAB Q10.00 199.00USD209.00END
YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END
PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END
\d+(?:\.\d+)(?!\d*END$)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}