const regex = /Q[A-Z ]*(?<!\b[A-Z]{2}Q)[\d.]+(*SKIP)(*F)|\d+(?:\.\d+)(?!\d*END$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Q[A-Z ]*(?<!\\b[A-Z]{2}Q)[\\d.]+(*SKIP)(*F)|\\d+(?:\\.\\d+)(?!\\d*END$)', 'gm')
const str = `ABC WS YMQ234.03WS TOY234.03USD468.06END
FUR BB LAB Q10.00 199.00USD209.00END
YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END
PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END
\\d+(?:\\.\\d+)(?!\\d*END\$)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}