import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^120/BHP\\d/(?P<lblreq_board>LBLREQ)-(?P<lblreq_id>\\d+)/(?P<mission>\\d{4}-\\d{2}-\\d{2}-Z0F\\d{4})/(?P<run>\\d+)/(?P<vehicle_time>\\d{18})/(?P<event_time_s>\\d+\\.\\d+)/(?:sweep_dir_\\d+/sweep_\\d+/)?image_(?P<channel>[a-z_]+)_000000000\\.png$";
final String string = "120/BHP4/LBLREQ-92/2018-06-13-Z0F0034/2/347742483826079513/315970791.448747000/sweep_dir_0/sweep_0/image_raw_ring_front_center_000000000.png\n"
+ "120/BHP4/LBLREQ-99/2018-07-05-Z0F0026/2/305006254539769513/315967941.329407000/sweep_dir_0/sweep_0/image_raw_stereo_front_left_000000000.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}