package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]+[^A-Z]*|[^A-Z]+`)
var str = `and some text hereOzievRQ7O37SB5qG3eLB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}