$re = '/[A-Z]+[^A-Z]*|[^A-Z]+/';
$str = 'and some text hereOzievRQ7O37SB5qG3eLB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);