using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" LLC | CO | CORP | DIV ";
string input = @" TEST LLC TEST CO TEST CORP TEST DIV
COMPUTING DEVICES CO DIV CLDC ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}