// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) LLC | CO | CORP | DIV ").unwrap();
let string = " TEST LLC TEST CO TEST CORP TEST DIV
COMPUTING DEVICES CO DIV CLDC ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}