package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([+]7)|8)(\W*[0-9]\W*){10}`)
var str = `+7 999 123 4567 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}