$re = '/(([+]7)|8)(\W*[0-9]\W*){10}/';
$str = '+7 999 123 4567 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);