#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[^&][\s_](SF) \d{8}"
Local $sString = "_zz&69050398_5d147597dd4aca00014351d9_zz sf 76064603RPL_Import_Create" & @CRLF & _
"_zm&69396284_5d165ed60198d60001fbef9a_75946292_Import" & @CRLF & _
"_aa&69385775_5d15782bdd4aca0001435432_supplier_info_import_template" & @CRLF & _
"_aa&68936210_5d16581add4aca00014355e9_76005473 RPL_Import_Create_Stand_to_Package" & @CRLF & _
"_ac&68728692_5d18fa52dd4aca00014356dd_SF 76113839 Copy of Generic_Export_AdvancePR_result - 2019-06-30T200450.090"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")