import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^&][\\s_](SF) \\d{8}";
final String string = "_zz&69050398_5d147597dd4aca00014351d9_zz sf 76064603RPL_Import_Create\n"
+ "_zm&69396284_5d165ed60198d60001fbef9a_75946292_Import\n"
+ "_aa&69385775_5d15782bdd4aca0001435432_supplier_info_import_template\n"
+ "_aa&68936210_5d16581add4aca00014355e9_76005473 RPL_Import_Create_Stand_to_Package\n"
+ "_ac&68728692_5d18fa52dd4aca00014356dd_SF 76113839 Copy of Generic_Export_AdvancePR_result - 2019-06-30T200450.090";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}