re = /^(?:https?:\/\/(?:www\.)?|www\.)[a-z0-9]+(?:[a-zA-Z0-9_\-\/\.]+)*(?::[0-9]{1,5})?(?:\/[a-z0-9]+)*(?:\.[a-z]{2,5})?$/mi
str = 'https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
https://ac/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx
http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://ac/abc/ms.aspx?Id=13
http://ac/abc/ms.aspx
http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
http://www.a.com/ab_c/ms.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end