// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:https?:\/\/(?:www\.)?|www\.)[a-z0-9]+(?:[a-zA-Z0-9_\-/\.]+)*(?::[0-9]{1,5})?(?:\/[a-z0-9]+)*(?:\.[a-z]{2,5})?$").unwrap();
let string = "https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
https://ac/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx
http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://ac/abc/ms.aspx?Id=13
http://ac/abc/ms.aspx
http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
http://www.a.com/ab_c/ms.aspx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}