$re = '/(?<!{){{[^{}]+}}(?!})/';
$str = '{{goodTag}} and {{{badTag}}} and {{{badTag}}
{{I should be found}} but {{{I shouldn\'t}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);