re = /(?<!{){{[^{}]+}}(?!})/
str = '{{goodTag}} and {{{badTag}}} and {{{badTag}}
{{I should be found}} but {{{I shouldn\'t}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end