$re = '/^((.*?)(\w+)( +\w+)*(\s|.*?))$/m';
$str = 'smith john go home your shift getting over in the 30 minute later then why you here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);