const regex = /<([^>]+)>(?:([^<]+))*(?=[^>]*\<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^>]+)>(?:([^<]+))*(?=[^>]*\\<)', 'gm')
const str = `<h2>Title of post</h2> 1 category <strong>task 1</strong> 1 category <strong>task 2</strong> 1 category <strong>task 3</strong>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}