re = /<([^>]+)>(?:([^<]+))*(?=[^>]*\<)/m
str = '<h2>Title of post</h2> 1 category <strong>task 1</strong> 1 category <strong>task 2</strong> 1 category <strong>task 3</strong>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end