package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(#\w+)|.+`)
var str = `This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to #% lose: #hope.`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}