use strict;
my $str = 'This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to #% lose: #hope.';
my $regex = qr/.*?(#\w+)|.+/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";