$re = '/[A-HJ-NPR-Z]{17}/';
$str = 'OXCIHKMBLPRQNTZWI
BQPUFWZDSDNUUKIUV
BVVXVWVCOASEASPWU
DCZACWJCZUWLBIVUI
KFLCKCAXUAZNKJVWR
QOOCGWILRYKYQTENT
YDSNHLBUHOACQBZUK
JAKUCQVYQKZFWRXWC
YNNXLIUQBJYAAGFKR
NTYAJLVNQDPMNIROG
QOAEGBNELNDIKQOWE
TAFDEHDRRSLOMQYHW
ZEWHUQUUMLBAIVSXJ
CPVYSKEDOOPJZUQPK
RWKNWQRZAEXMGMYNY
UOXQHITETYLRBVLBL
AJXTBSZZCYTBKXEIG
CJKFUDLOVAQMSNHYX
PDKBCPOBSFPQKQPPO
SRUZVKGSTEXUJUNTK
YZIOIZWTYKLVVBQNZ
MXUXSWHEWODYXXNHR
PRLPVFKGHNTNADBLX
ZQQNLKNJQJXQOZBKN
UIJAGGJPJCJWYKSKP
TPHDBXGEYTLDKICNK
LUFEZHOBWELPOQHSJ
CDJBNDZGNVGFBCCMT
WBMLMSUKNZETIRIBJ
PJLCZNMCCCFMCPYAS
YWYKSHVQRDCHTYIXB
NXDGJCLMICGSHRSLR
BZMIOYTZDXJQFBCDL
TFBWYPZPBQUVIPVPY
MENKAAMUWUTAUJAVN
ESEBVHLEZMLAZJXBQ
YGWVDMMPXXUYDMXUZ
XLEBIZQMMHJEPTRLW
JWJKFOATBUMERTNUR
IEMWASQEAUVHXSYLO
YEJKREPDABYZPGZAR
SMEJMYGTXHDWTRSTK
BUJGYIGPNFUZAWPJV
GLJZLAEMBZADLVOAZ
UDZLAZRUBZIANHNIW
GTJKPSXOIYATPACJA
BMDRMCRPOHASYZHSQ
MZXXUHTTKENOEMCQJ
VGQLJWLXZAQOWPDSE
MGULNKBQRIGDWVKZH
SLFBBOSNAJVBBRWLL
KQHFKFQYCHDHHDGYG
IRHWTIXJKCCNYUFNB
VDVCWZCVSXAEKQZGK
VUMKDQTIRWMLHEYIG
QMFXECJGIAYRUVUGK
ZLYVHWFCIQAPBGZFB
RTHPHXLYFEFLOVFVS
VBPSAADMVGTKNGIWI
IBEJPBAOPCOEJSAAE
KPRONONKFUPCGRYSI
TUJVHIDWCHXHNIOAC
THUQVGJTGEWJDSZYS
PEOVRKYJZUWEFZZFI
KGKKFJBRTQEYVYSBS
QIOITDCVULXALAJPD
DIRGGBSQCVDDPRQUZ
CXBGJEOXHOEEWVFVU
OZWAPYUBKTBAIMDSF
MVHVBRLQZPQXCTOEN
EVCKGZLQEMMPIAOCN
ILICNRUQDGRPEOUFF
XXMRPRMDHZOIAAEME
VTFDDBCXZPDUESHVG
NNUIFEIJFNZLTHOOC
AZQBWAVIMJWLNSUPM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);