import re
regex = re.compile(r"[A-HJ-NPR-Z]{17}")
test_str = ("OXCIHKMBLPRQNTZWI\n"
"BQPUFWZDSDNUUKIUV\n"
"BVVXVWVCOASEASPWU\n"
"DCZACWJCZUWLBIVUI\n"
"KFLCKCAXUAZNKJVWR\n"
"QOOCGWILRYKYQTENT\n"
"YDSNHLBUHOACQBZUK\n"
"JAKUCQVYQKZFWRXWC\n"
"YNNXLIUQBJYAAGFKR\n"
"NTYAJLVNQDPMNIROG\n"
"QOAEGBNELNDIKQOWE\n"
"TAFDEHDRRSLOMQYHW\n"
"ZEWHUQUUMLBAIVSXJ\n"
"CPVYSKEDOOPJZUQPK\n"
"RWKNWQRZAEXMGMYNY\n"
"UOXQHITETYLRBVLBL\n"
"AJXTBSZZCYTBKXEIG\n"
"CJKFUDLOVAQMSNHYX\n"
"PDKBCPOBSFPQKQPPO\n"
"SRUZVKGSTEXUJUNTK\n"
"YZIOIZWTYKLVVBQNZ\n"
"MXUXSWHEWODYXXNHR\n"
"PRLPVFKGHNTNADBLX\n"
"ZQQNLKNJQJXQOZBKN\n"
"UIJAGGJPJCJWYKSKP\n"
"TPHDBXGEYTLDKICNK\n"
"LUFEZHOBWELPOQHSJ\n"
"CDJBNDZGNVGFBCCMT\n"
"WBMLMSUKNZETIRIBJ\n"
"PJLCZNMCCCFMCPYAS\n"
"YWYKSHVQRDCHTYIXB\n"
"NXDGJCLMICGSHRSLR\n"
"BZMIOYTZDXJQFBCDL\n"
"TFBWYPZPBQUVIPVPY\n"
"MENKAAMUWUTAUJAVN\n"
"ESEBVHLEZMLAZJXBQ\n"
"YGWVDMMPXXUYDMXUZ\n"
"XLEBIZQMMHJEPTRLW\n"
"JWJKFOATBUMERTNUR\n"
"IEMWASQEAUVHXSYLO\n"
"YEJKREPDABYZPGZAR\n"
"SMEJMYGTXHDWTRSTK\n"
"BUJGYIGPNFUZAWPJV\n"
"GLJZLAEMBZADLVOAZ\n"
"UDZLAZRUBZIANHNIW\n"
"GTJKPSXOIYATPACJA\n"
"BMDRMCRPOHASYZHSQ\n"
"MZXXUHTTKENOEMCQJ\n"
"VGQLJWLXZAQOWPDSE\n"
"MGULNKBQRIGDWVKZH\n"
"SLFBBOSNAJVBBRWLL\n"
"KQHFKFQYCHDHHDGYG\n"
"IRHWTIXJKCCNYUFNB\n"
"VDVCWZCVSXAEKQZGK\n"
"VUMKDQTIRWMLHEYIG\n"
"QMFXECJGIAYRUVUGK\n"
"ZLYVHWFCIQAPBGZFB\n"
"RTHPHXLYFEFLOVFVS\n"
"VBPSAADMVGTKNGIWI\n"
"IBEJPBAOPCOEJSAAE\n"
"KPRONONKFUPCGRYSI\n"
"TUJVHIDWCHXHNIOAC\n"
"THUQVGJTGEWJDSZYS\n"
"PEOVRKYJZUWEFZZFI\n"
"KGKKFJBRTQEYVYSBS\n"
"QIOITDCVULXALAJPD\n"
"DIRGGBSQCVDDPRQUZ\n"
"CXBGJEOXHOEEWVFVU\n"
"OZWAPYUBKTBAIMDSF\n"
"MVHVBRLQZPQXCTOEN\n"
"EVCKGZLQEMMPIAOCN\n"
"ILICNRUQDGRPEOUFF\n"
"XXMRPRMDHZOIAAEME\n"
"VTFDDBCXZPDUESHVG\n"
"NNUIFEIJFNZLTHOOC\n"
"AZQBWAVIMJWLNSUPM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")