import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^'[^\\d]+)\\d+(\\.\\d+)?( m?g)?";
final String string = "'Anakinra 100 g, gentechnologisch hergestellt aus E. coli.'\n"
+ "'Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.'\n"
+ "'Anakinra 10.5 g, gentechnologisch hergestellt aus E. coli.'\n"
+ "'Anakinra 10, gentechnologisch hergestellt aus E. coli.'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}