re = /(?!^'[^\d]+)\d+(\.\d+)?( m?g)?/m
str = '\'Anakinra 100 g, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 10.5 g, gentechnologisch hergestellt aus E. coli.\'
\'Anakinra 10, gentechnologisch hergestellt aus E. coli.\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end