#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)LOG FORMAT.*\[(.*)\].*#"
Local $sString = "#KEEP THIS FILE IN THE SAME DIRECTORY AS __INIT.PY__, OTHERWISE IT WON'T WORK" & @CRLF & _
" " & @CRLF & _
"SETTINGS: " & @CRLF & _
"FILE TO BE SORTED: "C:\Temp\xmls - Copy" #IF YOU ENTER "in" HERE THEN YOU CAN ENTER FILENAME FROM THE CONSOLE" & @CRLF & _
"MINIMUM DISPLAY LEVEL OF LOGS: 10 #Warning = 30, Info = 20, Debug = 10, Notset = 0" & @CRLF & _
"LOG DELIMITER SYMBOL: "dupa" #A SYMBOL WHICH SEPARATES THE LOG FORMAT MODULES" & @CRLF & _
"FILE TO STORE LOGS: "DEFAULT" #TO CHANGE IT, PASTE FULL PATH OF THE CHOSEN DIRECTORY, RMEMBER TO PUT NAME.TXT AT THE END. DEFAULT = directory of __init.py__ " & @CRLF & _
"LOG FORMAT: [LEVELNAME, ASCTIME, MESSAGE] #A FORMAT IN WHICH LOGS WILL BE STORED IN THE FILE (Surrounded by [] brackets)" & @CRLF & _
"***" & @CRLF & _
"LIST OF ATTRIBUTES:" & @CRLF & _
"LEVELNAME, #Text logging level for the message ('DEBUG', 'INFO', 'WARNING', 'ERROR', 'CRITICAL')." & @CRLF & _
"ASCTIME, #Human-readable time when the LogRecord was created. By default this is of the form ‘2003-07-08 16:49:45,896’ (the numbers after the comma are millisecond portion of the time)." & @CRLF & _
"MESSAGE, #The logged message, computed as msg % args." & @CRLF & _
"FUNCNAME, #Name of function containing the logging call." & @CRLF & _
"FILENAME, #Filename portion of pathname." & @CRLF & _
"PATHNAME, #Full pathname of the source file where the logging call was issued (if available)." & @CRLF & _
"EMPTY #log will not be stored (IT SHOULD BE THE ONLY ONE MODULE IN THE LOG FORMAT)" & @CRLF & _
"" & @CRLF & _
"ADDITIONAL ATTRIBUTES:" & @CRLF & _
"CREATED #Time when the LogRecord was created (as returned by time.time())." & @CRLF & _
"LEVELNO #Numeric logging level for the message (DEBUG, INFO, WARNING, ERROR, CRITICAL)." & @CRLF & _
"LINENO #Source line number where the logging call was issued (if available)." & @CRLF & _
"MODULE #Module (name portion of filename)." & @CRLF & _
"MSECS #Millisecond portion of the time when the LogRecord was created." & @CRLF & _
"NAME #Name of the logger used to log the call." & @CRLF & _
"PROCESS #Process ID (if available)." & @CRLF & _
"PROCESSNAME #Process name (if available)." & @CRLF & _
"RELATIVECREATED #Time in milliseconds when the LogRecord was created, relative to the time the logging module was loaded." & @CRLF & _
"THREAD #Thread ID (NOT available)" & @CRLF & _
"THREADNAME #Thread name (NOT available)." & @CRLF & _
"***" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")