import re
regex = re.compile(r"LOG FORMAT.*\[(.*)\].*#", flags=re.MULTILINE)
test_str = ("#KEEP THIS FILE IN THE SAME DIRECTORY AS __INIT.PY__, OTHERWISE IT WON'T WORK\n"
" \n"
"SETTINGS: \n"
"FILE TO BE SORTED: \"C:\\Temp\\xmls - Copy\" #IF YOU ENTER \"in\" HERE THEN YOU CAN ENTER FILENAME FROM THE CONSOLE\n"
"MINIMUM DISPLAY LEVEL OF LOGS: 10 #Warning = 30, Info = 20, Debug = 10, Notset = 0\n"
"LOG DELIMITER SYMBOL: \"dupa\" #A SYMBOL WHICH SEPARATES THE LOG FORMAT MODULES\n"
"FILE TO STORE LOGS: \"DEFAULT\" #TO CHANGE IT, PASTE FULL PATH OF THE CHOSEN DIRECTORY, RMEMBER TO PUT NAME.TXT AT THE END. DEFAULT = directory of __init.py__ \n"
"LOG FORMAT: [LEVELNAME, ASCTIME, MESSAGE] #A FORMAT IN WHICH LOGS WILL BE STORED IN THE FILE (Surrounded by [] brackets)\n"
"***\n"
"LIST OF ATTRIBUTES:\n"
"LEVELNAME, #Text logging level for the message ('DEBUG', 'INFO', 'WARNING', 'ERROR', 'CRITICAL').\n"
"ASCTIME, #Human-readable time when the LogRecord was created. By default this is of the form ‘2003-07-08 16:49:45,896’ (the numbers after the comma are millisecond portion of the time).\n"
"MESSAGE, #The logged message, computed as msg % args.\n"
"FUNCNAME, #Name of function containing the logging call.\n"
"FILENAME, #Filename portion of pathname.\n"
"PATHNAME, #Full pathname of the source file where the logging call was issued (if available).\n"
"EMPTY #log will not be stored (IT SHOULD BE THE ONLY ONE MODULE IN THE LOG FORMAT)\n\n"
"ADDITIONAL ATTRIBUTES:\n"
"CREATED #Time when the LogRecord was created (as returned by time.time()).\n"
"LEVELNO #Numeric logging level for the message (DEBUG, INFO, WARNING, ERROR, CRITICAL).\n"
"LINENO #Source line number where the logging call was issued (if available).\n"
"MODULE #Module (name portion of filename).\n"
"MSECS #Millisecond portion of the time when the LogRecord was created.\n"
"NAME #Name of the logger used to log the call.\n"
"PROCESS #Process ID (if available).\n"
"PROCESSNAME #Process name (if available).\n"
"RELATIVECREATED #Time in milliseconds when the LogRecord was created, relative to the time the logging module was loaded.\n"
"THREAD #Thread ID (NOT available)\n"
"THREADNAME #Thread name (NOT available).\n"
"***\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")