import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^(([a-zA-Z0-9]){5,30})$)(?=(\\D*\\d){1,})(?=([^a-z]*[a-z]){2,})(?=([^A-Z]*[A-Z]){4,})";
final String string = "Detect\n\n"
+ "https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23\n"
+ "|a|b|c|AbcdEFGH123|456Ac\n"
+ "P A Abcde3Dd3FGhiDE Z H\n"
+ "ZZ123!Abcde3FGhiDE!123\n\n"
+ "Don't detect\n\n"
+ "IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3\n"
+ "NULLLLLLLLLLLLLLLLLLLLLLllll\n"
+ "|A|b|c|D|E|F|1|\n"
+ "<HeLLoWoRlD\"123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}