import re
regex = re.compile(r"(?=^(([a-zA-Z0-9]){5,30})$)(?=(\D*\d){1,})(?=([^a-z]*[a-z]){2,})(?=([^A-Z]*[A-Z]){4,})", flags=re.MULTILINE)
test_str = ("Detect\n\n"
"https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23\n"
"|a|b|c|AbcdEFGH123|456Ac\n"
"P A Abcde3Dd3FGhiDE Z H\n"
"ZZ123!Abcde3FGhiDE!123\n\n"
"Don't detect\n\n"
"IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3\n"
"NULLLLLLLLLLLLLLLLLLLLLLllll\n"
"|A|b|c|D|E|F|1|\n"
"<HeLLoWoRlD\"123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")