$re = '/\b(?<flagE>E[A-Z0-9]{1,4} [A-Z][0-9]{6})|(?<flagW>W [A-Z0-9]{1,4})|[A-Z0-9]{1,4}\b/m';
$str = 'X12 IK 888T
G I5J P9
544T ZUK ONI
E6U5 Z339988 T8 N55
886 W 9ZT T95';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);