import Foundation
let pattern = #"\b(?<flagE>E[A-Z0-9]{1,4} [A-Z][0-9]{6})|(?<flagW>W [A-Z0-9]{1,4})|[A-Z0-9]{1,4}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
X12 IK 888T
G I5J P9
544T ZUK ONI
E6U5 Z339988 T8 N55
886 W 9ZT T95
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)