import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S)[ \\t]*(?:\\r\\n|\\n)[ \\t]*(\\S)";
final String string = "Random Data, Company\n"
+ "2015\n\n"
+ "This is a sentence that has line \n"
+ "break in the middle of it due to extracting from a PDF.\n\n"
+ "How do I support\n"
+ "3 line sentence \n"
+ "breaks please?\n\n"
+ "HEADER HERE\n\n"
+ "The first sentence will \n"
+ "match. However, this line will not match\n"
+ "for some reason \n"
+ "that I cannot figure out.\n\n"
+ "Portfolio: \n"
+ "http://DoNotMatchMeBecauseIHaveAPeriodInMe.com \n\n"
+ "Full Name \n"
+ "San Francisco, CA \n"
+ "94000\n\n"
+ "1500 testing a number as the first word in\n"
+ "a broken sentence.\n\n"
+ "Match sentences with capital letters on the next line like \n"
+ "Wi-Fi.\n\n"
+ "This line has \n"
+ "trailing spaces after exclamation mark! \n";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}