use strict;
my $str = 'Random Data, Company
2015
This is a sentence that has line
break in the middle of it due to extracting from a PDF.
How do I support
3 line sentence
breaks please?
HEADER HERE
The first sentence will
match. However, this line will not match
for some reason
that I cannot figure out.
Portfolio:
http://DoNotMatchMeBecauseIHaveAPeriodInMe.com
Full Name
San Francisco, CA
94000
1500 testing a number as the first word in
a broken sentence.
Match sentences with capital letters on the next line like
Wi-Fi.
This line has
trailing spaces after exclamation mark!
';
my $regex = qr/(\S)[ \t]*(?:\r\n|\n)[ \t]*(\S)/p;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";