package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:The|An|A)\b`)
var str = `A boy
An apple
The cat
Abyss
There
Ant`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}