$re = '/^(?:The|An|A)\b/m';
$str = 'A boy
An apple
The cat
Abyss
There
Ant';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);